Welcome to the International Peugeot 309 Owners Club!

  • Sponsors


  • Sponsors

No brakes !

No brakes !

Postby miles1234 » Fri Aug 31, 2012 11:50 pm

Its not only Peugeots that give me problems , have not been out on my Kart for a year or more so decided to take it to Rye House last weekend .Gave it the once over a few days before , changed the engine oil , topped up the radiator , pumped up the tyres , gave the engine a run after changing the stale fuel then checked the brakes and found that the fronts were ok but got no effort at the rear .Brake fluid had been leaking and once i removed and stripped the caliper it was obvious that some of the piston seals on the 4 pot caliper were shot .
Image
The caliper is tiny and easy to work on , got 4 new seals and after a good clean up i reassembled it all . It is now back on the kart and working ok .Will have to find a day to take it out again before winter arrives .
User avatar
miles1234
Senior Member
 
Posts: 1805
Joined: Mon Apr 12, 2010 1:26 pm
Location: Enfield , London

Postby miles1234 » Sat Sep 08, 2012 11:34 pm

This is the kart in question . Caliper has been refitted after replacing the 4 piston seals and seems to be working ok now , just need to get out on it before its cold and wet .
Image
This is our other kart , it has the same TKM 4 stroke engine so they are fairly well matched for speed .My mate and i own half of each kart and we drive both , unfortunately i am slowest on both !
Image
User avatar
miles1234
Senior Member
 
Posts: 1805
Joined: Mon Apr 12, 2010 1:26 pm
Location: Enfield , London


Return to Work in Progress (non Peugeot)

Who is online

Users browsing this forum: No registered users and 0 guests

cron